466MHz unit: no power to HD after HD & RAM upgrade
Page 1 of 1

Author:  osimp [ Thu Sep 11, 2008 8:33 am ]
Post subject:  466MHz unit: no power to HD after HD & RAM upgrade

I have upgraded the HD and RAM in several clamshell iBooks without any issue whatsoever.

Using identical new components, I recently did this in a 466 MHz unit that was working prior to the upgrade, but find that the new HD is not recognized -- and neither is the original or any other HD that I try. It's pretty clear to me that the hard drive isn't receiving power.

I've tried replacing the new RAM, without any change in behavior.
(I've also tried a lot of other things, which I won't go into at the moment.)

If I try to boot to a CD or DVD (DiskWarrior or 10.4 Install disk, respectively), I get a darkened grey screen with the apple logo but no further activity. HOWEVER, if I disconnect whatever HD is in place I can then boot to either of these disks -- but of course I can't go anywhere, as the computer has no hard drive.

It has been suggested to me that, probably on the logic board, there is a surface mount fuse feeding the HD. While I could probably test that fuse (and possibly even replace it), I have not a clue as to its location.

Anyone have information on this? Or other suggestions?


Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group