Easy Search [ ? ]
 
* Login   * Register * FAQ    * Search

All times are UTC - 6 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 11 posts ] 
Author Message
 Post subject: Dead PowerBook after storage???
PostPosted: Mon Nov 24, 2003 6:36 pm 
I plugged in my PowerBook the other day and "Nothing, Zip, Zilch, Zero. It seems that it gets no power from the external power supply?? Anyone know how to get it going?? I tried a second power supply.


Top
  
 
 Post subject: Same Problem
PostPosted: Wed Nov 26, 2003 10:14 pm 
I have exactly the same problem. I repalced the power inverter board, but still nothing.


Top
  
 
 Post subject: Dead PowerBook
PostPosted: Fri Nov 28, 2003 3:30 pm 
From everything I can find its the power manager (pmu) but I haven't found a fix. Mine is the original 400 MHz, I can't see putting much money into it.

Let me know if you figure it out, I'll do the same.

Herb


Top
  
 
 Post subject: Dead Powerbook
PostPosted: Thu Dec 11, 2003 1:23 am 
My PB 400 and my friends of the same model had the exact same problem after being in storage for about 8 months. We found out after asking around and research online, that the internal clock battery needed to be reset. That consists not of using the reset button on the back like I had tried, but instead finding the battery ( it resides under the right palm rest when the powerbook is faced proper) unplugging the battery, and then plugging it back in after 1/2 an hour. worked like a charm for both machines. Good luck to you both.


Top
  
 
 Post subject: same problem - different model
PostPosted: Sat Jan 03, 2004 2:20 pm 
i have the exact same problem - no startup chime, no video, no hardrive spin noise, nada. i actually have a TiBo 667 (Combo/DVI/1GIG Ethernet) and what i am wondering is do i have a similiar battery and is it in a similiar location? i began to strip my machine when the problem first started a few days ago and i dont recall seeing a battery in the location you describe... but i'll check when i get home. just hoping for a 'miracle cure'i guess. ok any info would be greatly appreciated.
thanx
bvb


Top
  
 
 Post subject: Re: Dead PowerBook after storage???
PostPosted: Tue Jul 29, 2008 6:09 am 
same issue...
push button.. nothing happens.. no chime.. no video. no fans...

weird but the area where the HDD is gets warm then hot...

Odd but when my PB first started acting up when i would try to use it the mouse pad wouldn't work... Then it would freeze...

Its in pieces in front of me right now.. HELP


Top
  
 
 Post subject: Re: Dead PowerBook after storage???
PostPosted: Tue Jul 29, 2008 10:21 am 
PB Medic has some great take apart manuals onliune. Download one for reference.
The PRAM battery and PMMU are hooked to the logic board by way of a small rectangular connector located just above11 the DVD/CD drive. You can get at the connector by lifting the keyboard. Ulock the keyboard with a small jeweler's screwdiver (if locked) then pull back on the two slinding clips at the top of the keyboard. The keyboard should then lift up.
Really, the discription in the take apart manual does a much better job of describing it than I can and it has pictures!. You'll see where that pram batt and pmmu plugs in ny looking that the logic board removal section. You don't need to remov e the logic board to disconnect the PMMU. Do be sure to disconnect the power supplyu and remove the battery and make sure you have discharged any static electricity from your body.


Top
  
 
 Post subject: Re: Dead PowerBook after storage???
PostPosted: Fri Aug 29, 2008 9:01 am 
Offline
Site Admin

Joined: Mon Feb 24, 2003 1:58 am
Posts: 940
With the Powerbook G3 units and the early Powerbook G4 units, if the unit is left in storage for a while, the PRAM drains down, and the unit will not boot with a dead PRAM. This is especially true for the Pismo and Powerbook G4 400/500. To determine if the problem is the PRAM, simply unplug the PRAM from the logic board and then try to boot up the machine. If it boots, replace the PRAM. If it doesn't your problem lies elsewhere.

-Bradley
PowerbookMedic


Top
 Profile  
 
 Post subject: Re: Dead PowerBook after storage???
PostPosted: Tue Sep 09, 2008 12:30 am 
Bradley--
I've had what I think is the same problem with a TiBook 400, but I am confused about the correct fix. I understand that I need to
1) unplug the power adapter, remove the battery and let the computer sit until for awhile to discharge.
2) open it up and expose the PRAM battery using the instructions in the take-apart manual.
3) disconnect both the PRAM battery and the PMMU from the logic board and leave them disconnected for at least 30 minutes.
I don't understand what I should do after that. Miscellt (upthread) suggests that all that needs to be done is to plug the PRAM (and PMMU) back in and the computer should boot up, presumably after the power adapter has been plugged back in. The computer should not need any other fix if this works.
As I understand it, you are suggesting something different; that I unplug the PRAM battery only from the logic board and then try to boot with it unplugged. I presume that I would need to have the power adapter or battery in place to do that. If the computer boots without the PRAM battery plugged in, it means that the battery is bad and needs to be replaced. Is that correct?


Top
  
 
 Post subject: Re: Dead PowerBook after storage???
PostPosted: Tue Sep 09, 2008 12:17 pm 
Its work now !!!! Thanks !!!!

I unplug the PRAM battery, then put the back case back, then plug the power, then power-on successfully !!!

check this page, teach how to take out every parts, really helpful
http://homepage.mac.com/sysop/PhotoAlbum13.html


Top
  
 
 Post subject: Re: Dead PowerBook after storage???
PostPosted: Thu Sep 11, 2008 2:57 pm 
Offline
Site Admin

Joined: Thu Feb 27, 2003 6:35 am
Posts: 977
Right, if it boots without the PRAM plugged in, it means it is dead. Most models will work fine without the PRAM except it won't save your time and date and it won't until you get a new battery. I have seen where you can wire the PRAM back in after the machine is on to recharge it, but its pretty dangerous.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 11 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group