Easy Search [ ? ]
 
* Login   * Register * FAQ    * Search

All times are UTC - 6 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 
Author Message
 Post subject: No Power?
PostPosted: Mon Jun 04, 2007 6:08 pm 
Offline

Joined: Mon Jun 04, 2007 4:42 pm
Posts: 2
I have an old 500 MHz TiBook that I use on occasion that has stopped booting. The battery used to drain, but I'd be able to get it to start up by plugging it in for a little while before hitting the power key.

Now nothing happens, when the power adapter is plugged in the battery doesn't even start blinking to show that it's charging.

Any idea if this is fixable?


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 05, 2007 9:39 am 
Offline
Site Admin

Joined: Thu Feb 27, 2003 6:35 am
Posts: 977
If it still boots up without the battery, then I would first suspect the battery has died. If you can't get it to start at all, it is going to be the logic board. The battery would run you a little under $100 while the logic board will be closer to $300..


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 08, 2007 3:35 pm 
Offline

Joined: Mon Jun 04, 2007 4:42 pm
Posts: 2
hm, yea it doesn't boot at all, even when plugged in w/o the battery. I actually have two for this pbook so I'm pretty sure that's not the problem. Thanks for the tip.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group