PowerbookMedic.com
http://www.powerbookmedic.com/forum/

Advice on Wallstreet problems
http://www.powerbookmedic.com/forum/viewtopic.php?f=3&t=2442
Page 1 of 1

Author:  jruschme [ Wed Oct 14, 2009 10:57 pm ]
Post subject:  Advice on Wallstreet problems

I have a 300mhz Wallstreet which mostly works well, but has a couple of issues:

First, I think I have some version of the charging board problem. In my case, the system recognizes that a battery is installed. If the battery is less than fully charged (I have a VST charger), the system will show the charging icon for a while and then go straight to full, even though no actual charge appears to have occurred. If the battery is charged, the system will run on battery only.

Is this the typical symptoms for a charging board problem or should I be looking elsewhere?

Second, the PRAM is dead and doesn't appear to charge even when the system is left plugged in for many days.

Finally, neither the sleep light nor the volume and brightness buttons work. I've had the system apart, but didn't see any obvious damage to the cables to the board. Is this a typical problem? If so, what do I need to replace?

Thanks in advance...
John

Author:  justin-pbmedic [ Fri Oct 16, 2009 8:19 am ]
Post subject:  Re: Advice on Wallstreet problems

The charging issue will usually be an issue with the battery itself, but if you are confident the battery is fine, the charging board would be the next culprit.

For the PRAM issue, we sell the PRAM batteries on our site.

http://www.powerbookmedic.com/xcart1/product.php?productid=16270&cat=265&page=1

For the volume and brightness buttons, there is a cable that comes out of the top case underneath that panel. You can see if it is damaged or not plugged in all the way, but most likely this will require replacing the top case. We no longer offer this part, but you may be able to find a replacement on ebay.

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/