Easy Search [ ? ]
 
* Login   * Register * FAQ    * Search

All times are UTC - 6 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 
Author Message
 Post subject: Mid 2010 MBP battery and GPU problems, need some advice...
PostPosted: Wed Dec 26, 2012 6:27 pm 
Offline

Joined: Wed Dec 26, 2012 5:22 pm
Posts: 2
Hi all, hopefully someone here can help me out, I've got a mid 2010 MBP with some GPU and battery issues and I'm trying to figure out what to try/replace next.

Here's the mac:

mid 2010 15" with 2.8 i7 running 10.6.8 snow leo
8gb ram (memtest ran, confirmed no issues with either stick as well)
500gb HDD
1680x1050 screen
330gt 512mb version GPU with intel hd GPU switching


My problems: (as best I can explain...)
#1 the battery

Firstly, the battery. No matter what, my battery is throwing up the condition: "Replace Now" status to the system and will not charge at all. Looking at the system info I get this:


Battery Information:

Model Information:
Serial Number: W0018PU18BWZA
Manufacturer: SMP
Device name: bq20z451
Pack Lot Code: 0000
PCB Lot Code: 0000
Firmware Version: 0201
Hardware Revision: 000a
Cell Revision: 0158
Charge Information:
Charge remaining (mAh): 0
Fully charged: No
Charging: No
Full charge capacity (mAh): 0
Health Information:
Cycle count: 242
Condition: Replace Now
Battery Installed: Yes
Amperage (mA): 0
Voltage (mV): 9464

System Power Settings:
AC Power:
System Sleep Timer (Minutes): 10
Disk Sleep Timer (Minutes): 10
Display Sleep Timer (Minutes): 10
Wake On AC Change: No
Wake On Clamshell Open: Yes
Wake On LAN: Yes
Current Power Source: Yes
Display Sleep Uses Dim: Yes
GPUSwitch: 2
Battery Power:
System Sleep Timer (Minutes): 10
Disk Sleep Timer (Minutes): 10
Display Sleep Timer (Minutes): 2
Wake On AC Change: No
Wake On Clamshell Open: Yes
Display Sleep Uses Dim: Yes
GPUSwitch: 2
Reduce Brightness: Yes

Hardware Configuration:
UPS Installed: No
AC Charger Information:
Connected: Yes
ID: 0x0100
Wattage (W): 85
Revision: 0x0000
Family: 0x0085
Serial Number: 0x00731944
Charging: No


^You can see, the battery is being read as having on 242 cycles on it, but doesn't seem charge under any circumstances. I read somewhere that an indicator light would change color on the MBP when the battery was charging? Maybe on my magsafe? (forgive my stupidity - longtime UNIX, macpro, and hackintosh guy here - first time MBP owner :!: ) As of now I only have the magsafe connector lighting up a solid green.

I picked up a new DC/magsafe in board/connector from a friend earlier today and replaced this port on the side of the MBP. Unfortunately no change and I still just get the solid green light - so I think this is working correctly as is my 85w power adapter. I've tried SMC reset as well but I'm not even sure if it worked. Again, I read somewhere that the light on my magsafe should've turned red but Control+option+shift+power didn't seem to do anything for me.

Any thoughts/suggestions on these battery issues?


#2 The GPU

Also, a totally separate problem, my MBP seems to crash whenever switching from the intel GPU to the Nvidia graphics. Everything basic presents no problem, web browsing, word, simple desktop tasks. But running anything GPU intensive seems to crash my system, although I can't tell if it's actually becoming totally unresponsive or not. Once the Nvidia GPU should be running, I just end up with a black screen...

Gut instinct tells me this means bad GPU, bad driver, chip overheating and unsoldering from the main logic board, or vram failure. I'm just not sure where to start or what the next step should be for further troubleshooting to find the cause of the problem. I think SMC reset could also be useful for this but again, I don't know if SMC reset is working correctly or not.

Part of me wants to just update to mountain lion and see if there is a driver fix but that seems like a long-shot solution. Also my 10.6.8 is fully updated as is. I have also already cleaned the system of dust and went through everything, redoing the thermal compound and pads. The compound itself I cleaned up with AS Thermal remover/purifier. I also replaced that cheap/badly applied stock compound with Tuniq tx4, before reattaching and evenly tightening the heatsinks. In any case, I think I can now rule out the overheating as well.

Any thoughts here, what do you think I should try next with the GPU issue?


Top
 Profile  
 
 Post subject: Re: Mid 2010 MBP battery and GPU problems, need some advice.
PostPosted: Thu Dec 27, 2012 10:08 am 
Offline
Site Admin

Joined: Thu Feb 27, 2003 6:35 am
Posts: 977
for the battery issue, it should change to an amber color on the adapter when it's charging. if it is not switching it is either a battery issue or a PMU issue on the logic board.

for the GPU issue, it does sound like the nvidia chip is probably dead or needs to be reflowed. this would require a logic board repair or replacement.

It is hard to diagnose it past this point without trying a new battery to determine if the problems are solely with the logic board.


Top
 Profile  
 
 Post subject: Re: Mid 2010 MBP battery and GPU problems, need some advice.
PostPosted: Thu Dec 27, 2012 2:41 pm 
Offline

Joined: Wed Dec 26, 2012 5:22 pm
Posts: 2
justin-pbmedic wrote:
for the battery issue, it should change to an amber color on the adapter when it's charging. if it is not switching it is either a battery issue or a PMU issue on the logic board.

for the GPU issue, it does sound like the nvidia chip is probably dead or needs to be reflowed. this would require a logic board repair or replacement.

It is hard to diagnose it past this point without trying a new battery to determine if the problems are solely with the logic board.



Thanks justin! I'll keep working with the gpu for now and try to verify that one way or the other. Praying its not the PMU - I guess the cheapest fix at this point is to buy another battery and swap that in.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group