Easy Search [ ? ]
 
* Login   * Register * FAQ    * Search

All times are UTC - 6 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
 Post subject: Powerbook A1106 charging problems....
PostPosted: Mon Oct 22, 2007 9:43 pm 
Figure I'll just tell all the details I can about my Powerbook to get this figured out...

I bought a Powerbook on ebay for cheap and was aware of the sound not working on the powerbook. I figured a speaker problem or something could be fixed easily or I could live without the sound. Anyways, the sound sometimes works, but not always, and when it doesn't, I can plug in headphones and it will work through them. When the sound does work on the speakers, if I plug headphones in, it comes through both the headphones and the computer speakers. When the sound cuts out, it basically scrambles out and goes silent.

Now the big issue I'm having is with charging. The battery will only charge if the screen brightness is turned down or if the computer is off. Sometimes I have to fool with the adapter head while its plugged in to get the lights on the battery to start lighting up. Also, when I take the battery out, the charger doesn't power on the computer. Instead, some fans turn on and the computer wont boot. I have 2 batteries and I know 1 is in great condition, but its completely drained and it wont charge on this computer right now. I've taken the battery to work and put it in one of the powerbooks at work and it charges fine, but not in this one. It will however charge in this one if it has a little bit of juice in it. The other battery that I have is going bad and doesn't hold much of a charge. (30 minutes) The good one lasts 2.5 hours.

Also, where the power cord plugs in there is a dent on the case in the corner where the previous owner dropped it. I'm guessing this could be the cause of the problem.

I bought a brand new 65 watt adapter from this site and it still does the same thing. My guess is it's something internal like the DC-Board or whatever it's called, but I wanted to find out someone elses opinion before I drop the money on it. Everything else on the computer works fine except the Airport signal sucks unless i'm right up close. Is this possibly the logic board? I hope not, otherwise I've got a nice paperweight on my hands.

Thanks in advance. Hope this wasn't too long!


Top
  
 
 Post subject:
PostPosted: Tue Oct 23, 2007 8:29 am 
Offline
Site Admin

Joined: Mon Feb 24, 2003 1:58 am
Posts: 940
Definately sounds like a DC-IN issue. Replacing that part should also fix your speaker issue.

-Bradley
Powerbook Medic


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 25, 2007 8:53 am 
Thanks!


Top
  
 
 Post subject:
PostPosted: Sat Mar 01, 2008 12:30 pm 
As far as the airport card not working unless you're really close to the soucre, I had the same problemwith a G4 12" I bought recently. It turns out that if the antenna is not fully engaged, it behaves as yours. Take out the battery, locate the antenna wire and plug and push the plug in. If you feel a snap, the antenna wasn't plugged in all the way.


Top
  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group