Easy Search [ ? ]
 
* Login   * Register * FAQ    * Search

All times are UTC - 6 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 
Author Message
 Post subject: Is the battery dead?
PostPosted: Fri Apr 04, 2003 11:26 am 
All of a sudden, my battery doesn't seem to be charging. Everything else works running of the power adapter, just no charge. I've tried removing & replacing the battery just in case it was a bad connection, and resetting the power manager; no joy.

Seems this could be;

* A fault with the mains adapter - seems unlikely, given that everything else works
* Hardware fault somewhere inside; loose connection or something?
* The battery has just died

How to find out which it is? Obvious would be to swap bits around with another Pismo & narrow it down like that, but don't know anyone else round here with a Pismo...

Any suggestions or ideas most welcome!


Top
  
 
 Post subject:
PostPosted: Mon Apr 07, 2003 12:50 pm 
Offline
Site Admin

Joined: Thu Feb 27, 2003 6:35 am
Posts: 977
i would say its most likely a dead battery, but its also possible to be a bad charger board. I'd say buy a new battery and try that out first, because worst case you have two working batteries so no big loss. If its still broken after a new battery, its most likely the charger board which you can try installing yourself (its not the easiest repair) or send it in to us or another repair company.


Top
 Profile  
 
 Post subject: Is the battery dead?
PostPosted: Fri Apr 11, 2003 10:22 am 
Haven't y'all been watching the forums at Apple.com or Macintouch.com or in the usenet groups?

Battery charging issues have been attributed to OS X corrupting the battery charging microcontroller. Many PB and iB users have been experiencing very much reduced battery charge capacities.

Apple is aware of the issue and "is working on a fix" according to the support department.

Dave


Top
  
 
 Post subject:
PostPosted: Sun Apr 20, 2003 1:16 pm 
Offline
Site Admin

Joined: Thu Feb 27, 2003 6:35 am
Posts: 977
interesting, I'll have to do some research on it Thanks for the info.


Top
 Profile  
 
 Post subject: Re: Is the battery dead?
PostPosted: Tue Apr 22, 2003 10:11 am 
Interesting, but as I've never installed X on this machine (sorry Steve!) that can't be it. I'm starting to feel like its just the battery which has died. Symptoms now are that it charges, but incredibly slowly, like about a week to full charge, then discharges in under an hour.

Looking for someone near me with a Pismo/Lombard who I can swap batteries with just to check... I didn't fancy the PSU card replacement anyway, looks a pretty scary repair to me!


Top
  
 
 Post subject: just went through the card replacement
PostPosted: Tue Apr 22, 2003 10:03 pm 
Hi-

Have same problem-- a battery gone suddenly dead, won't charge, and I'm still at OS 9.2, no X installed. Thanks to the great take-apart guide available here, I got down to the card, replaced it and managed to reassemble everything in about an hour with no problem. However, the battery still won't charge, so next step is to buy and try the new battery, I guess. Thought for sure it was the card because of how suddenly it croaked.
Moral: you can take apart your powerbook. Just follow the instructions and keep the screws organized.


Top
  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group