PowerbookMedic.com
http://www.powerbookmedic.com/forum/

Help me revive my Pismo. Reward offered!
http://www.powerbookmedic.com/forum/viewtopic.php?f=1&t=2681
Page 1 of 1

Author:  imamac [ Tue Aug 03, 2010 5:54 pm ]
Post subject:  Help me revive my Pismo. Reward offered!

I had to stop using the pismo a couple of yrs ago after the port on the sound card went all wonky, it wouldn't hold a charge & eventually died. Today, i finally replaced the sound card, thinking that it would be THE fix (it had had no probs other than that, ever). I'm no computer whiz, but I'm fairly good with my hands, so am quite sure that I removed/reconnected everything accurately.
But...nothing. Dead as a post.
I've engaged in various combinations of: fiddling w/ the pram, the AC adapter, toothpicking the reset button & stabbing at the power key. I've gone back in and *very* firmly pushed down daughterboard/processor & then checked all the connections i'd made, etcetc.
Anyway, right now I've hooked it up to the adapter - with the PRAM in place but without the main battery in its slot - and am hoping that *maybe* it might charge over the next few days?
Boo hoo....
thanks:)

Author:  justin-pbmedic [ Fri Aug 06, 2010 3:30 pm ]
Post subject:  Re: Help me revive my Pismo. Reward offered!

try to turn it on with the PRAM unplugged first. If it still doesn't turn on, it is probably going to be a dead processor, but you can't rule out a dead logic board or sound/ac board.

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/