PowerbookMedic.com
http://www.powerbookmedic.com/forum/

Pismo - Won't turn on or charge
http://www.powerbookmedic.com/forum/viewtopic.php?f=1&t=1906
Page 1 of 1

Author:  verviana [ Sat Jul 26, 2008 4:43 pm ]
Post subject:  Pismo - Won't turn on or charge

So here's the story on my Pismo.

For a while now the battery has not been charging.
I'd been meaning to take it apart and figure out what the deal was, but I've just been using it plugged in for the last few days. This morning it suddenly shut down and won't start now at all even when it's plugged in.

I know for sure it's not the PRAM battery -- I've tried booting without the PRAM battery plugged in and get nothing.

I've tried resetting the PMU by holding in the little button in the back for a while before trying to restart.

I've even attempted the various "hold down assorted keys and start up the computer to reset stuff" starts, but of course none of them work because the computer won't, you know, turn on.

Clearly (I feel) it's just not getting power.
When it is plugged in, I hear this faint ticking noise near the place where it's plugged in -- as if maybe it's trying to make a connection and keeps failing?

Can anyone suggest what this may be? I'm totally up for taking the thing apart and replacing one or more parts -- I've done that a few times with this machine already -- I just don't know what parts I should try replacing. Can anyone point me in the right direction?

Author:  jbhanson [ Mon Jul 28, 2008 5:15 pm ]
Post subject:  Re: Pismo - Won't turn on or charge

Have you tried a new power adapter? Powerbook Medic has one that is fairly cheap. Even if that's not the ultimate solution, worst that can happen is that you end up with an extra for $25.

Author:  powerbookmedic [ Fri Aug 29, 2008 9:19 am ]
Post subject:  Re: Pismo - Won't turn on or charge

On a Pismo, if you are having a startup issue, and it isn't the PRAM, then there are a whole source of issues that could be the problem. The obvious place to start is the Power Adapter and the Sound / AC board. If the Sound / AC board feels a little loose when you plug in the adapter, then it is likely that the solder joints have come loose and the board needs to be replaced. That is a common issue in these units. The next thing to try is the processor which is likely to be the culprit as these processors are notorious for failing. The last stop would be the logic board. That is a less common failure in these units, but still a possibility.

-Bradley
PowerbookMedic

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/