PowerbookMedic.com
http://www.powerbookmedic.com/forum/

Pismo internal hard disk becomes read only whilst in use
http://www.powerbookmedic.com/forum/viewtopic.php?f=1&t=1189
Page 1 of 1

Author:  cashew [ Sat Aug 20, 2005 5:51 pm ]
Post subject:  Pismo internal hard disk becomes read only whilst in use

On my PowerBook G3 Pismo I've recently started having some very strange disk errors. These started under OS 10.3.9 and are still happening now I've upgraded to 10.4.2.

The problem is that occasionally my system disk will become read only, whilst I'm using it. I'm working on a file, saving away, then suddenly, when I try to save I get errors back and I can't create anything on that volume. It happens across various apps, without any apparent pattern and no warning. Other partitions on the same disk are unaffected.

I have to restart to get it back as writable, but occsionally the disk b-tree has been mangled and the volume needs repairing. A couple of times it's been so mangled I've had to erase it.

I copied my disk to my firewire iPod and booted from that and used the system for 2 weeks without any problems what so ever. I then installed a brand new internal harddisk, copied my working system from the iPod onto the new hard disk and within 48hrs it happened again.

The system.log often has a series of 'kernal[0]: disk0s10: I/O error' entries before I reboot. On reboot there's usually some journal replaying that happens 'kernel[0]: jnl: replay_journal: from: 3080704 to: 369152 (joffset 0x1cc000)'.

So it's malfunctioning on an old disk and a brand new disk and it works perfectly well running the same system from an external firewire disk.

Could this be some sort of IDE bus error or something? Does anyone know how to go about diagnosing such problems?

Thanks in advance,

Mark

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/